SlimBrowser crash under Windows XP in IE8 mode for certain s

Known issues, outstanding bugs and available workarounds

Moderator: SlimBrowser Forum Moderators

Post Reply
flashpeak
Advanced Member
Posts: 342
Joined: Sat Jan 25, 2003 5:26 pm

SlimBrowser crash under Windows XP in IE8 mode for certain s

Post by flashpeak » Mon Nov 22, 2010 3:29 pm

If you have configured SlimBrowser to use IE8 rendering mode, SlimBrowser might crash under Winxp when you view some improperly coded web pages (e.g., missing html tags). An example website is http://addons.eventscripts.com/addons/view/spawnpro . If you view the same website in IE, IE will automatically switch into compatibility view to display the page. However, such switching attempt would result in access violation in the case of SlimBrowser or any other browsers based on Microsoft trident engine.

On Windows 7, the situation is a little better. It doesn't crash but the tab view will attempt to display the web page first and then become completely blank after that.

If you run into such websites, you are recommended to view it in IE7 mode. To change the rendering mode, go to tools:options:misc, toggle the option "Enable IE8 rendering mode.".
Stephen Cheng
FlashPeak Support
Email: support AT flashpeak.com

johnb262
Newbie
Posts: 1
Joined: Thu Apr 07, 2011 10:49 pm

Re: SlimBrowser crash under Windows XP in IE8 mode for certain s

Post by johnb262 » Thu Apr 07, 2011 11:09 pm

Hi`

I am continuously crashing. I have not noticed what the pages are when it crashes. I looked under tools, options, ect. Ther is not anything there for me to choose a rendering mode. When it crashes I get the message "Slimbrowser is about to crash due to an exception.A dump file will be generated in the application data file". I have looked and there is nothing in the data file. I have used Slimbrowser for many years and would hate to have to change browsers if I cannot get this repaired. I have even tried uninstalling and reinstalling.

Thank You,
John

Anturako
Newbie
Posts: 1
Joined: Thu Mar 01, 2012 3:41 am

Re: SlimBrowser crash under Windows XP in IE8 mode for certain s

Post by Anturako » Thu Mar 01, 2012 3:43 am

This JUST started happening to me like 2 weeks ago. Didnt give it much thought at the time. But EVERY time I go to http://www.tomshardware.com
by browser locks up and I get a msg that "a script on the page is causing internet explorer to.." Freeze and force a restart of IE. Never had an issue with their site before. I tried to disable the script but froze before I could. Anyone have a clue what this may be attributed to? I know I can always just "not go there", but since it naver happened before, I want to know WHY now, ya know??

oftentired
Advanced Member
Posts: 910
Joined: Tue Mar 04, 2003 9:39 pm
Location: Las Vegas

Re: SlimBrowser crash under Windows XP in IE8 mode for certain s

Post by oftentired » Thu Mar 01, 2012 9:54 am

Anturako wrote:This JUST started happening to me like 2 weeks ago. Didnt give it much thought at the time. But EVERY time I go to http://www.tomshardware.com
by browser locks up and I get a msg that "a script on the page is causing internet explorer to.." Freeze and force a restart of IE. Never had an issue with their site before. I tried to disable the script but froze before I could. Anyone have a clue what this may be attributed to? I know I can always just "not go there", but since it naver happened before, I want to know WHY now, ya know??
Check Tools > Options > Advanced and see if you have a checkmark for Suppress Script Errors. If no checkmark go ahead and click it to check mark the selection and click OK to exit Options and see if the problem continues.
Slimbrowser Demo Videos

Relationships are ours to make; we define them, day by day,
by who we choose to love and how we choose to love them.
And, by these choices, define ourselves. ~~~Richard N. Patterson

knullass
Newbie
Posts: 1
Joined: Sat May 11, 2013 6:16 am

Re: SlimBrowser crash under Windows XP in IE8 mode for certain s

Post by knullass » Sat May 11, 2013 6:20 am

SlimBrowser used to crash in the past but the latest version made it very stable, I am very happy with it!

Pitkoncon
Newbie
Posts: 2
Joined: Tue Dec 03, 2013 4:56 am

Re: SlimBrowser crash under Windows XP in IE8 mode for certa

Post by Pitkoncon » Tue Dec 03, 2013 5:00 am

Slim Browser sounds fine but I can't try it, since it ALWAYS crashes when I double click on its exe file. I noticed other people are having the same problem and I can't tell which IE codes or other stuff I am using since I can't RUN Slim Browser. I use XP SP2. Any suggestions? Thanks!

oftentired
Advanced Member
Posts: 910
Joined: Tue Mar 04, 2003 9:39 pm
Location: Las Vegas

Re: SlimBrowser crash under Windows XP in IE8 mode for certa

Post by oftentired » Tue Dec 03, 2013 11:13 am

Pitkoncon wrote:Slim Browser sounds fine but I can't try it, since it ALWAYS crashes when I double click on its exe file. I noticed other people are having the same problem and I can't tell which IE codes or other stuff I am using since I can't RUN Slim Browser. I use XP SP2. Any suggestions? Thanks!
Using Internet Options accesible from your Start Menu, just type in "internet options", set the tab to open on startup to About:Blank, then see if SB crashes on startup or not.
Slimbrowser Demo Videos

Relationships are ours to make; we define them, day by day,
by who we choose to love and how we choose to love them.
And, by these choices, define ourselves. ~~~Richard N. Patterson

Pitkoncon
Newbie
Posts: 2
Joined: Tue Dec 03, 2013 4:56 am

Re: SlimBrowser crash under Windows XP in IE8 mode for certa

Post by Pitkoncon » Wed Dec 04, 2013 9:12 am

oftentired wrote:
Pitkoncon wrote:Slim Browser sounds fine but I can't try it, since it ALWAYS crashes when I double click on its exe file. I noticed other people are having the same problem and I can't tell which IE codes or other stuff I am using since I can't RUN Slim Browser. I use XP SP2. Any suggestions? Thanks!
Using Internet Options accesible from your Start Menu, just type in "internet options", set the tab to open on startup to About:Blank, then see if SB crashes on startup or not.
Did that, crashed again. Had to cold reboot... :( Thanks for the tip, anyway...

nordnord
Newbie
Posts: 3
Joined: Wed Jun 05, 2013 7:47 am

Re: SlimBrowser crash under Windows XP in IE8 mode for certa

Post by nordnord » Mon Apr 28, 2014 9:27 am

flashpeak wrote:If you have configured SlimBrowser to use IE8 rendering mode, SlimBrowser might crash under Winxp when you view some improperly coded web pages (e.g., missing html tags). An example website is http://addons.eventscripts.com/addons/view/spawnpro . If you view the same website in IE, IE will automatically switch into compatibility view to display the page. However, such switching attempt would result in access violation in the case of SlimBrowser or any other browsers based on Microsoft trident engine.

On Windows 7, the situation is a little better. It doesn't crash but the tab view will attempt to display the web page first and then become completely blank after that.

If you run into such websites, you are recommended to view it in IE7 mode. To change the rendering mode, go to tools:options:misc, toggle the option "Enable IE8 rendering mode.".
Under XP, I have seen few issues with IE8 mode, but with yesterday's announcement of a zero day exploit, I am hesitating to use SlimBrowser at all in IE8 mode. Is there a workaround? Tks and sorry for interrupting the thread.

vron1212
Newbie
Posts: 2
Joined: Wed Sep 14, 2016 2:19 am

Re: SlimBrowser crash under Windows XP in IE8 mode for certa

Post by vron1212 » Wed Sep 14, 2016 2:22 am

"Slimbrowser is about to crash due to an exception.A dump file will be generated in the application data file". I have looked and there is nothing in the data file. I have used Slimbrowser for many years and would hate to have to change browsers if I cannot get this repaired. I have even tried uninstalling and reinstalling.

WATEREUREKA
Newbie
Posts: 1
Joined: Sat May 19, 2018 1:39 am

Re: SlimBrowser not not showing whether

Post by WATEREUREKA » Sat May 19, 2018 2:01 am

SlimBrowser not not showing whether

Post Reply